87 fzr1000 reading 8 volts from fuel pump relay?

Moderators: Site Director, FZR Forum Moderators

nikko
Site Newbie
Posts: 19
Joined: Mon Mar 24, 2014 5:27 pm

87 fzr1000 reading 8 volts from fuel pump relay?

Postby nikko » Wed Mar 26, 2014 6:13 am

Hello gentlemen. Newbie here. Tried search but to no avail. A little history. Was given generously given non running bike. Replaced a faulty cdi box. Bike ran and rode a few months. Now no good. Replaced fuel pump and getting 8volts from relay. I'm wondering if there is a ground fix out there or where to start looking for problems. Thank you for your time.

DonTZ125
Moderator
Posts: 2214
Joined: Tue Dec 02, 2008 11:20 pm
Location: Scarberia, ON
Contact:

Re: 87 fzr1000 reading 8 volts from fuel pump relay?

Postby DonTZ125 » Wed Mar 26, 2014 8:22 am

Unplug the relay.
Unplug the fuel pump.
Key and kill switch ON, engine off.
Measure the voltage across the battery terminals.
Measure the voltage from the Red/White wires (they're connected) at the relay plug to battery -ve.
Key OFF.
Measure the resistance across the bLue/Black wire from the relay to the fuel pump.
Measure the resistance across the Black wire from the fuel pump to the battery -ve.
Measure the resistance across the fuel pump.
Reconnect the relay and pump.

nikko
Site Newbie
Posts: 19
Joined: Mon Mar 24, 2014 5:27 pm

Re: 87 fzr1000 reading 8 volts from fuel pump relay?

Postby nikko » Wed Mar 26, 2014 5:47 pm

Thank you DonTZ125. I did what you suggested. these are the results from what i understand.
unplugged relay and fuel pump. key and kill switch ON.
Voltage across battery terminal ...12.02V
Voltage from RED/WHITE white at relay to battery negative ...8.8V
Key OFF
Resistance of BLUE/BLACK wire from relay to fuel pump ... 0.3 ohms
Resistance of BLACK wire from fuel pump to battery negative ...0.2 ohms
Resistance across fuel pump ... 1.6 ohms
I do not know what these numbers are telling me but i thank you for your time. i am curious if my CDI box is bad again?

DonTZ125
Moderator
Posts: 2214
Joined: Tue Dec 02, 2008 11:20 pm
Location: Scarberia, ON
Contact:

Re: 87 fzr1000 reading 8 volts from fuel pump relay?

Postby DonTZ125 » Wed Mar 26, 2014 6:37 pm

Ok, it's not the pump, the wiring downstream of the relay, or the battery. The relay itself should be fine, and the TCI (*not* CDI - very different device) has nothing to do with it.

Start tracing the Red / White wire back from the relay socket, looking for corroded or otherwise damaged connector terminals, fraying or cuts in the insulation, or simple breaks in the copper itself.

nikko
Site Newbie
Posts: 19
Joined: Mon Mar 24, 2014 5:27 pm

Re: 87 fzr1000 reading 8 volts from fuel pump relay?

Postby nikko » Wed Mar 26, 2014 6:47 pm

Ok. Thanks for your time and advice. I will trace the wire when its not so cold. Thanks for the TCI correction. I will get back with some results.

nikko
Site Newbie
Posts: 19
Joined: Mon Mar 24, 2014 5:27 pm

Re: 87 fzr1000 reading 8 volts from fuel pump relay?

Postby nikko » Sun Mar 30, 2014 6:45 pm

Well... I traced the wires and found nothing noticeable so I uncovered the wire from its wrapper. Still looked good. I kept the battery hooked up to a trickle charger and attached the negative of my volt meter to the battery and started checking voltage on all positive wires. The battery read 12.6 volts with ignition on and the ignition switch read 10.3 volts. The TCI read9.6 volts.
I removed the fuse for the headlights and .... TADA! The fyel pump started working and was reading 11.2 volts.
The ifnition was patched but would it really cUse tgat much voltage drop or does it indicate old wiring? Where to start. Any advice is appreciated.

DonTZ125
Moderator
Posts: 2214
Joined: Tue Dec 02, 2008 11:20 pm
Location: Scarberia, ON
Contact:

Re: 87 fzr1000 reading 8 volts from fuel pump relay?

Postby DonTZ125 » Sun Mar 30, 2014 7:09 pm

Well, there's a good chance the problem is in the headlight wiring. Check the connectors, then the wiring.

nikko
Site Newbie
Posts: 19
Joined: Mon Mar 24, 2014 5:27 pm

Re: 87 fzr1000 reading 8 volts from fuel pump relay?

Postby nikko » Sun Mar 30, 2014 7:13 pm

Thank you Dontz125 im trying to post a picture of the switch wiring but im not sure how.

nikko
Site Newbie
Posts: 19
Joined: Mon Mar 24, 2014 5:27 pm

Re: 87 fzr1000 reading 8 volts from fuel pump relay?

Postby nikko » Wed Apr 09, 2014 7:35 pm

well... searched everywhere. decided to start bike without fuse to headlight. great cranking and volts. fuel pump running... no spark... this bike is wearing me out. i really think the TCI is shot again. these are getting hard to find. i just want to make sure its bad.

DonTZ125
Moderator
Posts: 2214
Joined: Tue Dec 02, 2008 11:20 pm
Location: Scarberia, ON
Contact:

Re: 87 fzr1000 reading 8 volts from fuel pump relay?

Postby DonTZ125 » Wed Apr 09, 2014 7:59 pm

It won't spark! Now what?

Go through that, see if that solves your spark issues. If it IS the TCI (not CDI - very different beast), the fact that the fuel pump works is a very good sign, and I can repair / replace the coil driver transistors.

nikko
Site Newbie
Posts: 19
Joined: Mon Mar 24, 2014 5:27 pm

Re: 87 fzr1000 reading 8 volts from fuel pump relay?

Postby nikko » Thu Apr 10, 2014 8:32 am

ok. thanks Don. i found the thread and will check it out. i still have the old TCI. if possible, would it be worth repairing it? thanks for helping me out.

DonTZ125
Moderator
Posts: 2214
Joined: Tue Dec 02, 2008 11:20 pm
Location: Scarberia, ON
Contact:

Re: 87 fzr1000 reading 8 volts from fuel pump relay?

Postby DonTZ125 » Thu Apr 10, 2014 12:12 pm

Swap the old TCI back in. If the fuel pump comes on, or either spark channel fires, then the odds are very good I can fix it.

nikko
Site Newbie
Posts: 19
Joined: Mon Mar 24, 2014 5:27 pm

Re: 87 fzr1000 reading 8 volts from fuel pump relay?

Postby nikko » Fri Apr 18, 2014 2:35 am

Update. all checks well with the wiring. looks like TCI again.
I opened up the original TCI and the ignition resisters checked ok. I think the eprom? is bad. I will open up my current TCI. Hopefully the resisters are bad and i can swap them out. 2 questions... 1)are any other TCI boxes compatible with my bike other than 87 and 88? 2) does the voltage regulator wiki fix work on my 87 fzr1000?
I am way out of my field of expertise here so i must givea shout out to my electronic guru Coop for helping me out and DonTz125 for the knowledge.

nikko
Site Newbie
Posts: 19
Joined: Mon Mar 24, 2014 5:27 pm

Re: 87 fzr1000 reading 8 volts from fuel pump relay?

Postby nikko » Fri Apr 18, 2014 9:18 am

oh well. the transisters in the old unit were good? what are the chances of both eproms going bad? I thinj i need to look elsewhere for the problem. I guess it was a coincidence that the bike ran once new TCI was put in. This is a basket case so far.

nikko
Site Newbie
Posts: 19
Joined: Mon Mar 24, 2014 5:27 pm

Re: 87 fzr1000 reading 8 volts from fuel pump relay?

Postby nikko » Tue Jul 08, 2014 9:08 am

UPDATE: Turns out that the voltage regulator was bad causing excess voltage to the battery. My new battery was fried. NOTE: It seems that the voltage to the coils are extremely critical. Please pay special attention to this. Thank you Dontz125 for all of your help and your wisdom to assist in solving the problem. I can officially call this post CLOSED and open another one. :cheers:


Return to “Electrical: MODs/How-To/Issues”

Who is online

Users browsing this forum: No registered users and 1 guest