LED TURN SIGNALS

FZR600 Forum

Moderators: Site Director, FZR Forum Moderators

User avatar
Gh0sT21
Site Newbie
Posts: 21
Joined: Thu Sep 27, 2012 3:05 am
Location: Romania

LED TURN SIGNALS

Postby Gh0sT21 » Tue Nov 01, 2016 3:48 am

Okay guys, as the subject says, I need help.
I few moths ago I bought LED turn signals, after a couple of weeks my rezistance gave up, so I bought new ones, but now it doesn`t work. All 4 turn signals are on, don`t blink, and my signal relay is gone.
Can someone help me with a mapping, or a picture of how it should look. Or what should I do in this case ?
I starting to rebuild my bike from absolute -1.
:notworthy: :notworthy: :notworthy:

User avatar
et_miller_87
100+ Posts
100+ Posts
Posts: 121
Joined: Sun Jan 31, 2016 11:55 pm

Re: LED TURN SIGNALS

Postby et_miller_87 » Tue Nov 01, 2016 7:11 am

If I understand your issue properly, you need diodes to the wires going to the instrument cluster

Sent from my LG-H811 using Tapatalk

User avatar
Gh0sT21
Site Newbie
Posts: 21
Joined: Thu Sep 27, 2012 3:05 am
Location: Romania

Re: LED TURN SIGNALS

Postby Gh0sT21 » Tue Nov 01, 2016 3:54 pm

yes, I think, its something white made out of ceramic, and it stands between the turn signal cable.
The thing is, I want to rebuild my bike from a total mess, next week I`m taking it to mechanic.
But I want to learn to do it myself too, so next time if that problem appears I wish to know what to do.

buzzawak
Level 1.5
Level 1.5
Posts: 198
Joined: Wed Apr 29, 2009 4:09 am
Location: Newcastle, Australia

Re: LED TURN SIGNALS

Postby buzzawak » Tue Nov 01, 2016 7:33 pm

So you are after the wiring diagram?
Which year fzr600 do you have ?

User avatar
Gh0sT21
Site Newbie
Posts: 21
Joined: Thu Sep 27, 2012 3:05 am
Location: Romania

Re: LED TURN SIGNALS

Postby Gh0sT21 » Wed Nov 02, 2016 1:32 am

It`s the 1991 3HE

User avatar
Gh0sT21
Site Newbie
Posts: 21
Joined: Thu Sep 27, 2012 3:05 am
Location: Romania

Re: LED TURN SIGNALS

Postby Gh0sT21 » Sun May 14, 2017 3:41 pm

well, after 7 months at the service, still nothing....they took back the bike and trying it again.
They completely fixed the engine part, clutch etc.
But somewhere is an electronic issue, and I guess its the Digital Ignition, a ordered one this weekend, so I hope after 2 weeks its set and done.


Return to “FZR600”

Who is online

Users browsing this forum: No registered users and 10 guests